AI Zone Admin Forum Add your forum

NEWS: survey on 3000 US and UK consumers shows it is time for chatbot integration in customer service!read more..

LPP2 questions
  [ # 31 ]

Right, so I think I’ve got the problem. Like everyone else, I changed the secrets to match and fixed the ‘undefined’ bit in server.js, started server.js just fine, but controlpanel etc aren’t connecting, and also are taking unusually long to load. I looked in my developer tools as per Merlin’s suggestion (thanks, Merlin), and here’s why controlpanel.html doesn’t connect:
(this forum won’t show the < and > signs, by the way)

script src="" /script
script src
="" /script
var URL=""

controlpanel.html is linking to files that do not exist online. In fact that domain doesn’t even exist anymore, so obviously then none of the jquery javascript functions will work. I reckon changing those paths to the local folders where the .js script files are located ought to fix it, but haven’t the time to try that yet. Can I just say: Bloody ‘ell mate.

script src="" /script
script src
="" /script
var URL=""

  [ # 32 ]

Tried it now, and that’s it alright. After changing the three paths in controlpanel.html as above, the table showing the connections shows up, and will show the clients’ names in green when you launch judge.html and confederate.html, to indicate when they’re connected.
From there on it works as it should; click New Round, click the alerts on the client htmls that a new round is beginning, then click Start Round.
I posted it to Github, I noticed they’re fixing stuff now.


  [ # 33 ]

Good catch Don,
With all the changes, it now works for me too.


  [ # 34 ]

Many thanks for your help! I have finally managed it to work.

Just one word of caution if anyone is carelessly trying to reuse work from last year competition (as I am doing actually). The “contents” part of the Json object is now simply “content”!


  [ # 35 ]

Hello, I have a problem with my LPP2 program that I can’t understand. After a normal connection, handshake, there is an unexpected close message from the server that I can’t explain :

OpCode = 1 not masked 42[“roundInformation”,”{\"roundNumber\":-1,
\"status\":\"Finished\", \"partners\":{}}”]

OpCode = 1 masked 2

OpCode = 1 not masked 3

OpCode = 1 masked 2

OpCode = 8 not masked

RoundInformation… : Normal exchange between client and server
OpCode = 1 masked 2 : Ping from client to server
OpCode = 1 not masked 3 : Pong from server to client. That’s ok
OpCode = 1 masked 2 : Second ping from client (after 30 seconds I suppose)
OpCode = 8 not masked : Unexpected connection close with no reason

The RFC6455 says :

5.5.1.  Close

  The Close frame contains an opcode of 0x8.

  The Close frame MAY contain a body (the “Application data” portion of
  the frame) that indicates a reason for closing, such as an endpoint
  shutting down, an endpoint having received a frame too large, or an
  endpoint having received a frame that does not conform to the format
  expected by the endpoint.

But here there is no body in the message (length = 00)

Have anyone an explanation ?

Full log :



  [ # 36 ]

Hi Denis
Just been reading your post.
I think you may have set your PING interval too long - 30 secs.
After 1st handshake you should get a message back from the server, something like:


time between PINGs 25 secs.
I set mine to 20 secs, just to be on the safe side, and so far I’ve had no problems.
I hope this helps.

When I preview this post an AD is set in the middle of it, whats going on?


  [ # 37 ]

The ads are an issue we’re working on, which should be resolved shortly. Sorry for the inconvenience, Stephen.


  [ # 38 ]
Stephen Mann - Jun 10, 2018:

Hi Denis
Just been reading your post.
I think you may have set your PING interval too long - 30 secs.

I saw it, I have modified the ping interval, and it’s works.

What I have not understood, it is why on some systems an interval of 30 s is enought, and why on others systems this interval is 25 s or less. Is there a parameter somewhere to change this ? Different version of node.js ?



  [ # 39 ]

I can’t seem to connect clients across a network. My interface is just a duplicate of the original confederate.html file, and that file fails to connect as well to begin with.

According to my browser console the problem is the Same Origin Policy disallowing Cross-Origin Resource Sharing (the html calls for, this is blocked). I have been unable to disable this for remote access on any browser, as available solutions to disable the policy or browser security (like the one Merlin posted) seem only to apply to local file access. I tried on IE, Firefox and Chrome in Windows Vista. The remaining option is to tamper with server.js, which is over my head.

If anyone knows how to get confederate.html to connect to the server on a remote computer, I’d love to hear, in case the AISB has this problem too.


  [ # 40 ]

Can’t you change IE security parameters ?


  [ # 41 ]

It sounds like you need to change the URL in the client.
In the client HTML file, change the lines that have:
http://127. ...
To the IP address of your server.

There are 3 lines just after the style block.


  [ # 42 ]

Okay, I changed the security parameters on IE9, updated my Firefox version, and installed the CORS Everywhere plugin on Chrome. Now I’m not getting reports about Cross-Origin any more, but still none of them are connecting.
IE shows no errors or activity, Firefox says it can’t execute the unknown instructions ‘frame-src’ and ‘worker-src’ (which appear in node modules like browser.js), and Chrome reports “failed to load resource: net::ERR_CONNECTION_TIMED_OUT” every 30 seconds that it sends a “GET” request. ( being the IP of the server computer)

@Merlin: That is noteworthy advice, but I did change the URL and the .js script links in the html to point in the right direction.

The LPP developer said he had no problems with confederate.html, so I don’t know, maybe it’s just my Node installation and I’m the only one having this problem.


  [ # 43 ]

I have had a lot of compatibility issues. The updates of win 10, chrome, and edge changed what works and what does not.

My suggestions:
Open the controller on the server system. This should list things that connect. Also, if you open it on a client system and don’t see the table, then you are having some kind of connection problem.
Double check the IP address of your server. My router dynamically assigns ip addresses, and it changes anytime I reboot. That means you need to change the IP address in the client. This caught me last year and caused me to add some code into server.js so that the console would display th IP it was using.


  [ # 44 ]

Many thanks for your suggestions. The controller doesn’t show the table on client side, so it’s entirely possible that I don’t know how to properly set up a network and permissions. IP addresses checked out though.
I’ve gone ahead and submitted my entry anyway. I’ve been ploughing on this problem for two days and since everything works just dandy on a single computer and the setup is nearly identical to that of a human confederate, I’ll just cross my fingers and assume they do know how to set up their own setup.


  [ # 45 ]

And all that mess is why I did not try to enter this year. It just wasn’t plug and play ready.


 < 1 2 3 4 > 
3 of 4
  login or register to react