AI Zone Admin Forum Add your forum

NEWS: survey on 3000 US and UK consumers shows it is time for chatbot integration in customer service!read more..

Trying to stop writing to serverlog999.txt

I am seeing trace information go into the /LOGS/serverlog3101.txt file but I don’t know why.

Here is my command line

ChatScript.exe port=3101 defaultbot=charlie buildfiles=..\.. users=C:\CHATSCRIPT_USERS Serverctrlz nouserlog noserverlog noserverprelog cache=20x1 VdecisionTreeHost= VdecisionTreePort=3102 

I have

:trace none 

at the bottom of both build files

$cs_trace=-1 is commented out everywhere it appears in my code

Here is the header of the severlog3101.txt file. I believe it shows that both user tracing and server tracing are turned off.

System startup createsystem Fri May 24 15:00:43 2019
Server ChatScript Release Version 9.31 pid
0 32 bit Windows compiled Apr 30 2019 12:06:28 host=
:   dict:2097151 fact:800000 text:100000kb hash:215127 
:80x80kb cache:1x20kb userfacts:100 outputlimit:80000 loglimit:80000
:  dict=68896  fact=129448  heap=1382136 Compiled:May24'19-14:57:13 by version 9.31 "bcbsal0"
Build1:  dict=536  fact=721  heap=193000 Compiled:May24'
19-14:59:10 by version 9.31 "bcbsal1"
$decisionTreePort 3102
Used 51MB
dict 270,428 (21634kbhashdepths 73674.68728.39499.19092.8464.3572.1351.493. 270428 unusedbuckets 73674 fact 216,471 (10390kbheap 13496kb
(6400kbcache (20kb)
Free 114MBdict 1,826,722 fact 583,529 stack/heap 86,503KB 

*** Server WIDE OPEN to :command use.

Began server 9.31 compiled Apr 30 2019 12:06:28 on host port 3101 at Fri May 24 15:00:47 2019 serverlog:0 userlog0
Server ready 
logfile:LOGS/serverlog3101.txt serverLog:0 userLog:0

....Enter Topic:

Topic: ~introductions~1 linear Gambits

I have looked in the topic_user_bot.txt file and it has $cs_trace=0

I have cleared the TMP and TOPIC directories and rebuilt 0 and 1

if I connect to the server and do


i see

>    :trace
Sent 15 bytes of data to port 3101 
Disabled simple
: echo match ruleflow variables
Disabled mild detail
output pattern input prepare
Disabled deep detail
always fact hierarchy infer json label macro pos query sam
ple sql substitute tcp topic user userfact treetagger usercache varassign
  Enabled simple
  Enabled mild detail
  Enabled deep detail
fact label macro pos sample tcp topic user varassign
  Disabled simple
: echo match ruleflow
  Disabled mild detail
output input prepare
  Disabled deep detail
always hierarchy infer json query sql substitute userfac
t treetagger usercache 

I can do

:trace none 

and it all turns off. But this is not a solution for a production environment, especially when we start using Docker.

Does anyone have any ideas why this I am tracing into the serverlog?


  [ # 1 ]

In your version of CS, if you have any trace on and have nouserlog so no user logging can be saved, the traces go to the server log (in my revision internal this is no longer true).

So, somehow you have some traces enabled.  have you done a grep across all your code to see if you do :trace anywhere?

What CS release are you using? Have you tried just running Harry as a server (using the server batch files) and seeing if tracing happens there? 


  [ # 2 ]

to all who find this. There was an issue with me defining topics in my build0 files. Bruce fixed the issue in the latest version of CS. Problem solved! I no longer get any log files when I don’t want them.

Thanks to Bruce for such a quick fix. (I am posting this a few weeks later)


  [ # 3 ]

An update. On version 9.41. doing a :build 0 still turns on lots of logging. I have grepped my code and there are zero instances of “trace” anywhere in the code.

Whenever I do a build, either 0 or 1, the following tracing gets turned on for all of the topics that are in my files1.txt.

Enabled simple: variables
  Enabled mild detail: output prepare
  Enabled deep detail: fact json label pos query sample usercache varassign
  Disabled simple: echo match ruleflow
  Disabled mild detail: pattern input
  Disabled deep detail: always hierarchy infer macro sql substitute tcp topic user userfact treetagger

I have triple checked this by doing :trace none before doing the :build 0 or :build 1. Every time after the build, the trace is turned on and upon examination, the trace is turned on for every topic defined in my files1.txt file. Even when I do a :build 0.

Bruce, can this be fixed?


  login or register to react